import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+_work_\\d{3}.blob.obj";
final String string = "online_work_000.blob.obj\n"
+ "online_work_001.blob.obj\n"
+ "online_work_002.blob.obj\n"
+ "online_work_003.blob.obj";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}