const regex = /\w+_work_\d{3}.blob.obj/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+_work_\\d{3}.blob.obj', '')
const str = `online_work_000.blob.obj
online_work_001.blob.obj
online_work_002.blob.obj
online_work_003.blob.obj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}