using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\{\{(\w+):(\w+)\}\})";
string input = @"fdfd{{dsfdss:dssssasa}} fdsfdsfds";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}