using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S*).*\[(.*)\]\s""(\S*)\s(\S*)\s([^""]*)""\s(\S*)\s(\S*)\s""([^""]*)""\s""([^""]*)""$";
string input = @"52.20.244.144 - - [24/Aug/2015:06:50:57 -0400] ""GET /hol/contact.action?subject=Question+about+Junior+Essay+Contest&title=Susan+Harlow&webUserKeys=13900 HTTP/1.1"" 200 5921 ""http://holsteinusa.com/news/press_release2015.html"" ""Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.24 (KHTML, like Gecko) Chrome/19.0.1055.1 Safari/535.24""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}