# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<!\w)'((?:.|\n)+?'?)(?:(?<!s)'(?!\w)|(?<=s)'(?!([^']|\w'\w)+'(?!\w))))/"\1"/g;t' <<< "'The Joneses' car'. Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India. 'Hey'! you'll, I'm, he's,
some random text 'what if it's
multiline?'. 'I'm one of the persons''
'the classes' hours'
'the Joneses' car' guys' night out
'two actresses'
roles' and 'the hours' of classes'
'The Joneses' car won't start'"