#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\pL\pM _()$&"'0-9\/!@^=+*-])+"
Local $sString = "こ ん に ち はLkbnfbj"dsfdfdsfdsd48446こ んfds您好/!@^=+dsd"--હે લોLsfsPNOPpdsd"Hi"Hallåfdfsdf fdsfsdfdsfdfddcgd こ-ん-に-ち-は હેલો হ্যালো Салом வணக்கம் สวัสดี Olá Hallåनमस्ते'''''dsdd*sdd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")