using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\pL\pM _()$&""'0-9\/!@^=+*-])+";
string input = @"こ ん に ち はLkbnfbj""dsfdfdsfdsd48446こ んfds您好/!@^=+dsd""--હે લોLsfsPNOPpdsd""Hi""Hallåfdfsdf fdsfsdfdsfdfddcgd こ-ん-に-ち-は હેલો হ্যালো Салом வணக்கம் สวัสดี Olá Hallåनमस्ते'''''dsdd*sdd";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}