$re = '/([\pL\pM _()$&"\'0-9\/!@^=+*-])+/';
$str = 'こ ん に ち はLkbnfbj"dsfdfdsfdsd48446こ んfds您好/!@^=+dsd"--હે લોLsfsPNOPpdsd"Hi"Hallåfdfsdf fdsfsdfdsfdfddcgd こ-ん-に-ち-は હેલો হ্যালো Салом வணக்கம் สวัสดี Olá Hallåनमस्ते\'\'\'\'\'dsdd*sdd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);