re = /([\pL\pM _()$&"'0-9\/!@^=+*-])+/
str = 'こ ん に ち はLkbnfbj"dsfdfdsfdsd48446こ んfds您好/!@^=+dsd"--હે લોLsfsPNOPpdsd"Hi"Hallåfdfsdf fdsfsdfdsfdfddcgd こ-ん-に-ち-は હેલો হ্যালো Са лом வணக்கம் สวัสดี Olá Hallåनमस्ते\'\'\'\'\'dsdd*sdd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end