import Foundation
let pattern = #"([\pL\pM _()$&"'0-9\/!@^=+*-])+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"こ ん に ち はLkbnfbj"dsfdfdsfdsd48446こ んfds您好/!@^=+dsd"--હે લોLsfsPNOPpdsd"Hi"Hallåfdfsdf fdsfsdfdsfdfddcgd こ-ん-に-ち-は હેલો হ্যালো Салом வணக்கம் สวัสดี Olá Hallåनमस्ते'''''dsdd*sdd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}