# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a\K|\G(?!^)[^>]*?\K'|<img\K|\G(?!^)[^>]*?\K'//gmi;t' <<< "<a href='fooo' >hai</a><img src='foo' >hai'b"