using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\K|\G(?!^)[^>]*?\K'|<img\K|\G(?!^)[^>]*?\K'";
string substitution = @"";
string input = @"<a href='fooo' >hai</a><img src='foo' >hai'b";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}