const regex = /"@\"^(([A-Za-z]))$\""/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"@\\"^(([A-Za-z]))$\\""', '')
const str = `rrrr`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);