using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\D)[+-]\d+)|\d+";
string input = @"a := -1
y := +2
b := 2-2
c := 3+4
z := 20 + 42
funcao(-1)
funcao( -1)
funcao(a, -1)
-1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}