$re = '/((?<=\D)[+-]\d+)|\d+/';
$str = 'a := -1
y := +2
b := 2-2
c := 3+4
z := 20 + 42
funcao(-1)
funcao( -1)
funcao(a, -1)
-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);