package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z][^\s]*)`)
var str = `I Love To Work`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}