$re = '/(?<=\{\{)([\S\s]+?)(?=\.$)/';
$str = '{system 1}} asdfd{{system2.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);