$re = '/^[a-zA-Z]+(?:[\s.]+[a-zA-Z]+)*$/';
$str = 'S. Harish Kumar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);