import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z' ]+)\\s+([0-9a-z, ]+)$";
final String string = "Sokolov 19, 20, 23 ,25\n"
+ "Hertzl 80,82,84,86\n"
+ "Hertzl 80a,82b,84e,90\n"
+ "Aba Hillel Silver 2,3,5,6,\n"
+ "Weizman 8\n"
+ "Ahad Ha'am 9 13 29";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}