re = /((?:[^_]*(?:_)?){5})_(.*)/
str = 'ks_hdfkshdkfhsdkfhskdhfkshdfksdhfskdhfksdhfskhdfkshkfhksdhfksdhfkshdkfhsdkfhskdhfksdfkdssfdsdfsfd
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end