#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)From:((?!From:).)*?Subject:"
Local $sString = "From: h" & @CRLF & _
"From:b" & @CRLF & _
" xyz" & @CRLF & _
"Subject: testing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")