$re = '/([\d]+)/';
$str = 'test 13231 test 123123
123 asdfasdf
1a2a3 a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);