#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:10\.31\.(?:6|7)\.\d{1,3}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"
Local $sString = "10.31.7.1" & @CRLF & _
"" & @CRLF & _
"10.31.7.1" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)