using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,2}\/\d{1,2}|https:\/\/docs\.google\.com\/spreadsheet\/ccc\?key=[\w\n]*&usp=drive_web&pli=1#gid=\d{1,}";
string input = @"Hi All
12/14日訂購的廠商為 一品魯肉飯
請於下列連結中登記
https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=126
請於上午10:10前登記完成, 逾時不候.
============================================================================================
12/15日訂購的廠商為 北一排骨便當
請於下列連結中登記
https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=138
請於上午10:10前登記完成, 逾時不候.
謝謝您的配合";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}