#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^dados/series/[a-z0-9A-Z\-].+/?$"
Local $sString = "dados/series/ola-mundo" & @CRLF & _
"" & @CRLF & _
"dados/series/ola-mundo/" & @CRLF & _
"" & @CRLF & _
"dados/series/ola-mundo/configs" & @CRLF & _
"" & @CRLF & _
"dados/series/ola-mundo/configs/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")