$re = '/\[amenities (.*?)\]/i';
$str = ' Input: BEST AVAILABLE RATE , [Amenities BREAKFAST] , [amenities WIFI] AND FITN ? - MORE IN HP ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);