re = /\[amenities (.*?)\]/i
str = ' Input: BEST AVAILABLE RATE , [Amenities BREAKFAST] , [amenities WIFI] AND FITN ? - MORE IN HP '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end