$re = '/(?(?=.*?"state":"FIXED")"a":"(.*?)"|"b":"(.*?)")/m';
$str = '{"b":"abc","a":"def","state":"FIXED"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);