const regex = /^(?:(\1?+#)\d+)++$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\1?+#)\\d+)++$', 'gm')
const str = `#12##235
#123
#12##235
#1234##12###368
#1234##12###368####22235#####723356
#123#123#123#123
#
####
##123
#123###456
#123##456##789
##1##2
#1##2##2
#1#2
test ing test #1
1#1
1##1
##1##1
#1##1###1##2#1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}