#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)\b\d{2}-?\d{6}-?\d{6}-?(?:\d{1,2})?\b"
Local $sString = "22-412314-441123-1" & @CRLF & _
"" & @CRLF & _
"22-412314-441123-12" & @CRLF & _
"" & @CRLF & _
"2a-412314-441123-12" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22412314-441123-1" & @CRLF & _
"" & @CRLF & _
"2241231444112312" & @CRLF & _
"" & @CRLF & _
"22412314441123123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")