$re = '/(?P<booknumber>\d+(?:\.\d+)?)\)\s+(?P<item>.*?)\s+\(\d+(?:\.\d+)?\s+Dollars\)/';
$str = '1.0) The Ugly Duckling (TUD) (10 Dollars)
1.0) Little 1 Red Riding Hood (9.50 Dollars)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);