using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"STARTKEYWORD (.+?)(?:$| ENDKEYWORD$)";
string input = @"STARTKEYWORD some text I want to extract ENDKEYWORD
STARTKEYWORD some text I want to extract";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}