$re = '/<\/?(?!img|a)[^>]+>/';
$str = ' <p>So in this</p>
<p>HTML <strong>with nested tags</strong></p>
<p>It should remove <i>everything</i> except <a href="#">This link</a>
and this <img src="#" alt="image" /> but it also needs to kep the textual content</p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;