# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\/?(?!img|a)[^>]+>"
test_str = (" <p>So in this</p>\n"
" <p>HTML <strong>with nested tags</strong></p>\n"
" <p>It should remove <i>everything</i> except <a href=\"#\">This link</a>\n"
" and this <img src=\"#\" alt=\"image\" /> but it also needs to kep the textual content</p>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.