using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<b.*?>(.*?)<\/b>";
string input = @"Your <b class =\""b_1\"">1</b> payment due is $4000.Your <b class =\""b_1\"">2</b> payment due is $3500. Your <b class =\""b_1\"">3</b> payment due is $5000.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}