use strict;
my $str = 'jon52_rs - £5
caneflagi - £5
Tehhguam - £5
Clapu - £5-05';
my $regex = qr/^(\w+)(.*)/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";