re = /(?<=>)(\d+)\D(\d+)\D/m
str = '<span class="value">
Price:<br>
<span style="color:white">23,07€ </span>
</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end