import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "wid.*\\d";
final String string = "<img class=\"image-resize\" src=\"http://hugoboss.scene7.com/is/image/hugoboss/test%2Dimg?wid=100&crop=0,0,960,650\" name=\"mainimg\" id=\"mainimg\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}