re = /wid.*\d/
str = '<img class="image-resize" src="http://hugoboss.scene7.com/is/image/hugoboss/test%2Dimg?wid=100&crop=0,0,960,650" name="mainimg" id="mainimg"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end