Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
%
[+-]?[0-9]{1,3}(?:,?[0-9]{3})*\.[0-9]{2}
%
g
Input 1
1
New
0000000000.00 000,000,000,000,000.00 0