use strict;
my $str = '01.0
02.0
02.5
50.0
10.0
20.0
30.5
40.5
50.5
59.0
59.5
60.0
99.9
59.1
34.9
60.5
';
my $regex = qr/^(?!00)[0-5]\d\.[05]|60\.0|99\.9$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}