$re = '/output.*?\K\d[\d.]*/m';
$str = 'Approxmiate output size of output: 2.268 kilobytes
some entirely different string: 2.268 kilobytes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);