re = /\bhttps?:\/\/\S*(?=(?:(?!http)[\s\S])*https?:\/\/\S*backbone\.com)/i
str = 'dfjSKsfkfkSFKfdvsfdvsdv https://text.com
from https://test2.com sdjgdsdh
https://backbone.com
from jfsjfskf https://backbone.com jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end