#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d\d([-./ ]?)\d{3}\1\d{4}$"
Local $sString = "55.635.8828" & @CRLF & _
"72/683/1582" & @CRLF & _
"86 942 7682" & @CRLF & _
"581827998" & @CRLF & _
"" & @CRLF & _
"56.855/9856" & @CRLF & _
"56 4559428" & @CRLF & _
"52-355/9984"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")