import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s|^)\\b\\d{3}-\\d{2}-\\d{4}\\b(?=\\s|$)";
final String string = "John Doe SSN# 123-12-1235\n"
+ "100-123-45-1234-99\n"
+ "John Smith, SSN, 123-45-1234\n"
+ "100-123-45-1234-99\n"
+ "123-45-1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}