import re
regex = re.compile(r"(?<=\s|^)\b\d{3}-\d{2}-\d{4}\b(?=\s|$)", flags=re.MULTILINE)
test_str = ("John Doe SSN# 123-12-1235\n"
"100-123-45-1234-99\n"
"John Smith, SSN, 123-45-1234\n"
"100-123-45-1234-99\n"
"123-45-1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")