$re = '/(?<=\W)(?!$)|(?!^)(?=\W)/m';
$str = ';aaa,bbb.ccc,ddd-eee;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);