// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\s*(صح)\s*").unwrap();
let string = "
تستخدم أجهزة مشغلات الصوت إم بي 3 MP3 Player كبديل لمعامل اللغة. صح 73";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}