use strict;
my $str = '<ul>
<li class="myclass">blablabla 1</li>
<li class="myclass">blablabla 2</li>
<li class="myclass">blablabla 3</li>
</ul>';
my $regex = qr/(?:<ul>)?(\s*<li class="myclass">(.+)<\/li>\s*)(?:<\/ul>)?/p;
my $subst = '<div class="newClass">$2</div>\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";