const regex = /<sup>(.*?)<\/sup>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<sup>(.*?)<\\\/sup>', 'g')
const str = `<sup>3</sup>
<sup>4</sup>`;
const subst = `<a href="#$1"><sup>$1</sup></a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);